Sie befinden sich hier: Startseite > Excel > Praxistipps für Microsoft Excel > Excel Zellen nur bei Zahlenformat berechnen 

Rechnen mit Excel nur, wenn Zelle der Tabelle eine Zahl ist

In diesem Excel Tutorial soll der Umgang mit der Funktion ISTZAHL von Excel gelernt werden. Die Funktion ISTZAHL liefert den Wert wahr zurück, wenn sich in der darauf bezogenen Zelle eine Zahl befindet und den Wert falsch, wenn das Format davon abweicht.

In einer kleinen Excel Übung sollen Werte einer Spalte der Excel Tabelle mit einer Rechenoperation in der nächsten Spalte verarbeitet werden, aber nur dann, wenn sich in der Ausgangszelle von Excel eine Zahl befindet. Ansonsten soll die Ausgabe der Tabellenzelle leer sein. Zu realisieren ist diese Wenn-Dann-Sonst Ausgabe am besten mit der Wenn Funktion von Excel.

Die Excel Tabelle hat als Stand die folgenden Eintragungen. In Spalte A erkennt man, dass Zahlen und Texte gemischt eingetragen sind.

Verwendung der Excel Funktion ISTZAHL

Berechnung von Excel Zellen, nur wenn Zahlen beinhaltet sind

Jetzt sollen in Spalte B die Zellen aus Spalte A mit einem Multiplikator multipliziert werden, aber nur dann, wenn sich in Spalte A eine Zahl befindet. Ansonsten sollen zwei Möglichkeiten vorgestellt werden, die mit WENN-DANN-SONST in Excel entweder das Feld leer lassen oder den Text aus Spalte A übernehmen.

Folgende Excel Formeln können dazu benutzt werden:

Excel Formel für ISTZAHL mit "leerer" Ausgabe:

=WENN(ISTZAHL(A3);A3*$B$1;"")

 

Excel Formel für ISTZAHL mit Ausgabe der Ursprungszelle:

=WENN(ISTZAHL(A3);A3*$B$1;A3)

In den Excel Formeln wurde die Zelle B1 mit dem $-Zeichen festgestellt, da diese sich beim Ausfüllen der Formeln in die Excel Spalte nicht verändern soll.

Die Ausgabe der beiden Excel Funktionen ist in der folgenden Abbildung dargestellt. Beide Male wird mit der ISTZAHL Funktion von Excel zuerst als Bedingung abgefragt, ob in der Zelle eine Zahl steht, dann wird diese mit dem Multiplikator multipliziert. Ansonsten unterscheidet sich die Ausgabe in der Excel Tabelle in Spalte B - mit leerer Ausgabe - und in Spalte C mit der Ausgabe der Originalzelle.

Berechnung mit ISTZAHL in einer Wenn Funktion in Excel

Die eingegebenen Excel Formeln sind auf der folgenden Abbildung dargestellt:

Excel Formeln für ISTZAHL Abfrage

Das Tutorial zur Anwendung von Microsoft Office hat Ihnen weitergeholfen?

Ich freue mich über Ihre Verlinkung. Kopieren Sie dazu einfach den folgenden Code an eine geeignete Stelle in Ihrer Internetseite. Vielen Dank!


Letzte Aktualisierung: 14.02.2014
Jetzt die LEAD digital testen!
officecoach24.de - Hilfe für Word, Excel, Powerpoint und Visio

Suche

Zuletzt erstellt & aktualisiert

Weiter empfehlen

Sie finden diese Seite empfehlenswert? Sagen Sie es bitte weiter und unterstützen Sie somit die Erweiterung des Inhalts:

Werbung


Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ ? ]